Can't update OM-D firmware 1.5 version

Started Oct 2, 2012 | Discussions thread
OP madzazulu Senior Member • Posts: 1,311
Re: 2hrs & still can't download v1.5

rhtK7 wrote:

- Started with v1.2 already in camera

- Deleted my "Downloader" copy and reloaded "latest" version

- Ran Downloader.  Afterwards checked camera.  Had v1.4

- Based on forum comments, tried process again to get to v1.5

- After starting Downloader, I get a popup message "Your Olympus Digital Camera Updater has already been installed the latest version.  There is no need for you to update it"  The bad english is bad (typed exactly here).

- Have tried many, many times.  Even with the USB cable connected to camera but camera off, how can it possibly know what firmware is on the camera?  What if I had two OMD's?????

- As I only have v1.4, I actually have nothing better than v1.2.  

I don't know where to go from here.  H E L P !!!!  Any comments are appreciated.



The way I did it was I went to the Control Panel and uninstalled the older version of updater and install the one I downloaded, after that it first went to ver 1.4 and then after I turned off and on the camera and rerun the updater it figured out that it needed to go to ver 1.5. I've also removed the SD card before the installation process.

Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow