Metz 50 AF-1 won't fire with Olympus OM-D E-M5

Started Sep 30, 2012 | Discussions thread
OP elfidge New Member • Posts: 8
Re: Metz 50 AF-1 won't fire with Olympus OM-D E-M5

Thanks for all the replies guys!!

Replies below.

Otherwise the thing is that the 44 refused to work at photokina, so I'm wondering if it's some kind of Olympus thing - I have v1.2 installed in the camera, which has some other issues I hear. I'm completely baffled

Gravi wrote:

That is strange, as it should work. I have a couple of Metz 48 af-1 flashes (the 50 is the replacement for that one) that work perfectly, the only thing is that the focal length is displayed wrong (aps-c vs 43rds crop factor problem).

Some suggestions, I hope they do not sound all too stupid, but sometimes simple things can do the job:

  • Did you try another set of batteries?

Brand new Eneloop XXs fully charged, only ever used in.. this flash!

  • Does the green light show after a second or maybe three seconds after turning it on?


  • Does the flash work off-camera? Put it on, wait till the green light shows, and push that test button. It should fire.

Test fires all good, as many as you want

  • Is the camera set to RC mode? If so, disable that!

RC mode is off

  • Any other camera settings that prevent the flash from firing?

Even tried resetting the camera to defaults - still nothing. Not sure what settings would cause it not to fire?

  • Are you sure it is the Oly/Pana version? The 48 AF-1 has it printed at the back above the hotshoe.

Yup it says "For Oly" above the metal shoe

  • Did you push it in the hotshoe far enough? Some flashes do not fit like a glove and need some tiny bit of extra force to make the contacts align.

Tried that earlier, thinking it may be unaligned, but it fires when putting it in to the hotshoe and won't go any further. Plus the pin that extends out locks it in place.

  • do all the contacts of the flash look OK? are they sticking out of the shoe?

Yup all look fine, rubbed them

  • Is the flash in the right mode? TTL?


  • Did you upgrade the firmware? (you should not have to I think)

Yup got it to 1.2

If the above points do not give an answer, you might have a broken flash.

elfidge wrote:

Hi guys, hoping someone's an idea about this!

I've had my Om-D E-M5 for several months now and decided to get a larger more powerful gun for it. At photokina last week I tried out the FL-600R and decided the build quality and output just couldn't justify the price. So I picked up a 50 AF-1 instead.

When I tried the FL-600R it worked fine - as expected in full auto mode. The tiny unit that shipped with the camera also works, however, even at the Metz stand, the 44 wouldn't work. As they didn't have a 50, I assumed it must be the unit and/or some setting on my camera.

Now I've the 50, the same problem persists - it communicates at some level as I can change shutter speed and the corresponding distance changes, but it doesn't seem to send the focal length, nor does it trigger. I've tried everything I can possibly think of - any ideas at all would be really gratefully appreciated.

Thanks in advance

-- hide signature --


Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow