Problems with Phottix Odin

Started Sep 17, 2012 | Discussions thread
Shop cameras & lenses ▾
ForumParentFirstPrevious
Flat view
KBStudio Regular Member • Posts: 256
Problems with Phottix Odin

Just finished extensive tests on the Canon Odin and 4 receivers. Hardware consists of a 5DM2, 2-430EXs,1-430EX II, and a 580EX II. All features seemed to be behaving as advertised,HSS,Zoom,ETTL, except the misfires. If I try to shoot a quick sequence with my 5DM2, I will get one good exposure and after that on receiver or another will misfire. I have replaced batteries in both the speedlights and the receivers. This results in maybe two or three good exposures before the misfires begin again. The 580EX II seems to have the fewest misfires. I did get a six shot sequence without a misfire when I set the strobes to Manual and 1/128 power. All strobes and receivers were within 5-10 feet of the camera so it isn't a distance issue. It does appear that HSS adds to the number of misfires while Normal and Manual have fewer. I am using the latest firmware 1.20 and Sanyo Eneloop rechargeable batteries all freshly charged.

This is not the performance that was reviewed or advertised.

 KBStudio's gear list:KBStudio's gear list
Canon EOS 5D Mark II Canon EOS 5D Mark III Sony Alpha 7R Sony Alpha 7R II Canon EF 400mm f/5.6L USM +7 more
Canon EOS 5D
If you believe there are incorrect tags, please send us this post using our feedback form.
ForumParentFirstPrevious
Flat view
ForumParentFirstPrevious
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow