S100 after 2nd repair

Started Sep 1, 2012 | Discussions thread
Shop cameras & lenses ▾
Flat view
gail Forum Pro • Posts: 13,721
S100 after 2nd repair

When Canon returned my repaired s100 following the lens problem, I felt there was something wrong with the camera. I just couldn't put my finger on it.

Some images were slower to write to the memory card than I remembered and there were more blurred images than I ever had before. I posted a number of photos and discussed it in some threads in this forum. I started believing it was user error. I had been using the S90 for six weeks, and thought maybe I just forgot about the feel of the S100.

About a week and a half later, the LCD went, so back the camera went to Canon for a second repair.

I received my S100 last evening and have taken a number of test photos, all to my satisfaction. I immediately could feel that the camera was peppy like I had indeed remembered it.

So all appears well the second-time around. I hope it stays that way.

In case anyone is wondering, I checked the serial number. Canon did not replace the camera. The one I sent them twice is the once I got back.
My S100 Galleries ~ http://www.pbase.com/gailb/canon_s100
My Canon S100 Blog: http://www.digicamhelp.com/topics/camera-logs/canon-s100/

 gail's gear list:gail's gear list
Canon PowerShot SD700 IS Canon PowerShot S90 Canon PowerShot S100 Panasonic Lumix DMC-FZ200
Canon PowerShot S90
If you believe there are incorrect tags, please send us this post using our feedback form.
Flat view
Post (hide subjects) Posted by
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow