Canon software will not install on my Mac

Started Aug 5, 2012 | Discussions thread
Eric8255 New Member • Posts: 14
Re: Canon software will not install on my Mac

I too have been having this problem.

I have a MacPro and a MacBook Pro. I was unable to load Canon Utilities disk 25.0 as an upgrade to much older canon utilities suite or 25.2 (latest one) that canon sent me.

I assumed that there was something wrong with the operating system so re-installed the same via the HD Partition. On the MacPro this was a clean install but on the MacBook it was not.

However it did load on the MacBook but I got the same message on the MacPro. I copied and pasted that software over my network and all was fine. I also had the same problem with the Canon Map Utility (having just purchased a GP-E2) so was able to repeat the operation.

This is fine if it is not necessary to instal drivers. If you do I doubt copying & pasting will be sufficient and that an instal is necessary but I have not had to try this.

I have seen in the manual for the Map Utility that Mac OX 10.6 - 10.7 requires that the operating system must be pre-installed on the computer i.e. a computer that was upgraded or even a clean re-instal satisfies the requirements.

Of course this is inconsistent with the MacBook being OK after a re-instal.

I have assumed that there must be some difference between the MacBook and MacBook Pro - possibly that the latter has an intel processor but the former does not which may explain why one installed and the other did not - but maybe my Lion Download had a problem so I will download again when I have time and see if the problem recurs.

As Canon says pre-installation of the OS is needed unless you have such a computer it follows that it would be foolish to buy any Canon products that require a driver such as printers,scanners etc as you would probably end up returning them.

The other option is to use Parallels and a virtual windows machine - which I tried (windows 7) and it worked without problem but it depends on whether you want windows on your computer.

Hope the above workaround for non-driver software helps.


ulto wrote:

I have an issue installing the Mac software on my 2010 Imac with Lion OS.

When trying to install Canon 5d mk III software (EOS utilities, etc) from the CD, I do have a message 'you need administrator privilege to install'. I did download the softwares from Canon website with the same result.

Of course I am administrator on my iMac. Does anybody have similar issue?


 Eric8255's gear list:Eric8255's gear list
Leica Q Canon EOS 5DS R Panasonic Lumix DMC-GX8 Canon EOS 5D Mark IV Canon EF 24mm f/1.4L II USM +3 more
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow