S100 Repair Experience

Started Jul 19, 2012 | Discussions thread
skisagooner Forum Member • Posts: 90
Story of my S100

So I'm an S100 user residing in Malaysia (hot and humid place). I bought my camera in the 4th of March, 2012. Was a happy consumer. My camera's serial number was within the 'could be affected' range.

http://support-my.canon-asia.com/index.jsp?fuseaction=support&prod_type=notices-digitalcameras-powershots100

On the 24th of July, 2012, I was in a football stadium watching a game when I first saw the lens error message. A press of the power button solved it, and the camera functioned back to normal. I ignored the event.

The next time I saw the message was on the 28th of August, 2012. I was in a park at night, and the lens error was in full force. This time the lens really could not retract, and when I hit the power button...

1) Rapid clicking sounds
2) Start up screen appears + 6 beep sounds.
3) Lens error message:

Lens Error
Will shut down automatically
Restart camera

I am sending it to Canon's "Corporate Head Office, Showroom & Service Centre" first thing in the morning tomorrow. Good thing it's not terribly far away from where I live.

Will keep it posted on this thread.

 skisagooner's gear list:skisagooner's gear list
Canon PowerShot S100
Post (hide subjects) Posted by
(unknown member)
(unknown member)
(unknown member)
(unknown member)
(unknown member)
(unknown member)
(unknown member)
(unknown member)
(unknown member)
(unknown member)
(unknown member)
(unknown member)
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow