Warning for using filters with LT55

Started Jun 5, 2012 | Discussions thread
Shop cameras & lenses ▾
ForumParentFirstPrevious
Flat view
martin1g New Member • Posts: 14
Warning for using filters with LT55

I have noticed a big difference in image quality with the DMW-LT55 and my cheap UV-filter from Roxcore..Sure, I shouldnt be surprised but I have used this filter on my Nikon D300 with good optics and didn´t notice any big difference..I use to have Hoyas or B+W filters but for some reason I bought the Roxcore (not sure the brand is available worldwide, but there should be similar cheap filters) I got better results with the i-zoom setting than with the LT55 wich seemed strange, so I took the filter off and it was a big difference, both with and without the teleconverter but I think the difference is bigger with it, probably due to internal reflections inside the LT-55´s attachment tube. I hope its because of the filter being bad, so I can use a filter as long its a good quality one...Its nice to be able to have a filter for protection,

the attached photos, first time I post pictures here, hope it works. Check them out in 100%, I have cropped them from original jpegs, nothing else.

Nikon D300
If you believe there are incorrect tags, please send us this post using our feedback form.
ForumParentFirstPrevious
Flat view
Post (hide subjects) Posted by
ForumParentFirstPrevious
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow