E-M5 firmware bugs, report them here

Started Apr 23, 2012 | Discussions thread
OP Jonas B Forum Pro • Posts: 14,596
Update May 10

1: Camera sometimes locks up when reviewing image in the EVF

  • confirmed, and reported to Olympus

2: No IS when shooting a video using legacy lenses

  • confirmed, and reported to Olympus

3: Built In EVF Grid no effect in Style 3

  • confirmed, and reported to Olympus

4: OIS not used for stills exposures (with some µ4/3 lenses)

  • confirmed, and reported to Olympus

5: No Auto replay on LCD if moving the camera...

  • confirmed, and reported to Olympus

6: EVF auto-switch takes you out of playback mode, & disrupts to...

  • not confirmed, status unknown

7: EVF style 1 amd 2 not working when using EVF only

  • confirmed but status unknown

8: Reduced battery life when using battery in grip only

  • confirmed, and reported to Olympus

9: No magnified view available when in Movie mode

  • confirmed but status is unknown

10: AF goes to one end for no reason

  • not confirmed, status unknown

11: Blinking highlights and shadows lost after manually having enlarged the the viewfinder view

  • not confirmed, status unknown

12: Blinking highlights and shadows lost after tapping the LCD to move the focus point

  • not confirmed, status unknown

13: Camera locks up with some Panasonic lenses (most common the 20/1.7)

  • confirmed and reported to Olympus

14: Battery grip shutter button gets confused with HG ZD lenses in some cases

  • not confirmed, status unknown

15: Banding when using the Panasonic G20/1.7

  • confirmed and reported to Olympus

16: ?

Feel free to submit anything else you have found. If there is a bug annoying you beyond description please report it to Olympus making sure they hear it from more than a few users.

Bugs not yet confirmed but catching your interest - please check your camera's behavior and report about your findings. If you can confirm the bug please let Olympus know about it and then post a commen as a reply to this post.

Remember a bug is something not working as it is supposed to work.There is a difference between finding a bug and coming up with an idea for firmware updates.

Thank you to all who contributed this far!

Jonas

(you can mentally imagine OLED where I wrote LCD, OK?)

Post (hide subjects) Posted by
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow