Spyder 3 not recognised on Dell XPS 15 L502X?

Started Apr 11, 2012 | Discussions thread
Flat view
siudar New Member • Posts: 2
Spyder 3 not recognised on Dell XPS 15 L502X?


I wonder if someone could help me get Windows 7 to recognise my Spyder 3 on my Dell XPS 15 laptop. I have Elite ver 4.02 but it will not recognise the device - in the driver it says "This device is disabled because the firmware of the device did not give it the required resources. (Code 29)". I have totally removed all traces of Elite and tried Express with same error.

The Spyder works fine on an XP laptop. Other deivces work fine via USB on XPS.

Laptop spec:

Windows 7 home premium SP1 64 bit
16gb RAM
i7-2670QM processor
Boot drive - Intel 520 SSD 120gb
Data drive - 750gb 7200 rpm
2 x USB 3 ports
1 x esata port
nvidia GT540m graphics
1920x1080 B+RGLED screen

Datacolour have been no help - they say it's because of USB 3.0 - this can't be true as I see many others using successfully on same setup. This was my reply from Datacolour:

thank you for your message.

The different USB3.0 chipsets are not implemented in Windows7. The drivers are not working in a consistent way which results in problems with some of them. This is an issue which can't be resolved from our side. Microsoft gave us the information that this will be implemented (and solved) in Windows 8.

I'm aware that this is an information which doesn't help you. But please understand that I'm not able to give you a solution with these USB 3.0 ports and Windows7.
Thank you for your understanding.

Any help and/or advise is much appreciated

Reuben Siuda, UK

Nikon Coolpix L5 Samsung i7
If you believe there are incorrect tags, please send us this post using our feedback form.
Flat view
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow