Front Dial issue - A900 - Skipping images

Started Feb 8, 2012 | Discussions thread
Shop cameras & lenses ▾
ForumParentFirstPrevious
Flat view
lonewolf69 Veteran Member • Posts: 3,365
Front Dial issue - A900 - Skipping images

Hi Folks,

The oft talked about skipping images with the FRONT dial has finally happened to me. IT was never an issue with me on the A700. This is not a deal breaker but I just wanted to note that the SKIPPING is only occuring when reviewing pictures doesn't affect shutter speed or aperature size A/S/M modes...?

So questions:

1. Has there been an "OFFICIAL SONY" fix on this problem?
2. How has everyone else been dealing with this problem?
3. Does the canned air or electronic cleaning solution really work?

4. I don't want to send UNIT into SONY to repair and get charged $$$$ for out of warranty issue.

Carl, Nordstrom, Richard, Lucas??? any and all advice would be greatly appreciated...!

thank in advance!

-- hide signature --

-Alex

From the minds of Minolta to the imagination of Sony, Alpha, like no other.

http://www.pbase.com/lonewolf69

 lonewolf69's gear list:lonewolf69's gear list
Sony Alpha DSLR-A100 Sony Alpha DSLR-A700 Sony Alpha DSLR-A900 Sony SLT-A77 Sony Alpha a99 +2 more
Sony Alpha DSLR-A700
If you believe there are incorrect tags, please send us this post using our feedback form.
ForumParentFirstPrevious
Flat view
ForumParentFirstPrevious
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow