HELP! How to reset my a33 :(

Started Dec 8, 2011 | Discussions thread
ForumParentFirstPrevious
Flat view
Lineypi
Lineypi Contributing Member • Posts: 822
HELP! How to reset my a33 :(

My a33 seems to have crashed Everytime I turn it on (with or without an SD card inside) it comes up with a message saying the SD card needs to be restored in order to continue taking photos with it. I tell it to restore the card and it just brings up a message saying something along the lines of 'please insert SD card you were using'.

I made the mistake of trying to read an SD card that had been used in my a77 in the a33 and this happened

It seems like it isn't even aware of whether or not an SD card is inserted in the camera and none of the menu buttons or anything like that do anything.

If there's a way to hard reset the a33 and restore it to defaults then I'd say that's my best bet, but I've got no idea how to do it!

Can anyone help? I know we found a way to hard reset the a77 back when it was having firmware issues so I'm hoping I can do something similar for the a33..??

I really want this camera working again soon as I've got an event that I'm taking photos at this weekend and it'll be tough trying to do it without a second body

 Lineypi's gear list:Lineypi's gear list
Sony RX100 Sony SLT-A33 Sony SLT-A77 Sony 70-200mm F2.8 G Sony DT 18-250mm F3.5-6.3 +5 more
Sony SLT-A33 Sony SLT-A77
If you believe there are incorrect tags, please send us this post using our feedback form.
ForumParentFirstPrevious
Flat view
ForumParentFirstPrevious
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow