Sony 50mm f1.4 disappointing on A77 (?)

Started Nov 30, 2011 | Discussions thread
Shop cameras & lenses ▾
ForumParentFirstPrevious
Flat view
Bart1969
Bart1969 Junior Member • Posts: 37
Sony 50mm f1.4 disappointing on A77 (?)

Hello,

I was going to buy the Sony 50mm f1.4 and I tried it at the shop on my A77, but the test shots showed such disappointing results that I gave up immediately. I compared it with the kit 16-50 f2.8 and the difference in sharpness was so huge that even the seller didn't even try to convince me.. he said "that is an old design that doesn't perform so well with new sensors with high pixel density".

I think the lens was a bad sample, can't believe that what I found should be considered as a normal consequence of old design lens used on modern sensor. Unfortunately they had one lens only so I couldn't test another one.

Anybody did any experience with A77 and this lens? Is it worth to search for another sample? Other large aperture lenses worth to look at (apart from the Zeiss that cost more than I'm willing to spend at the moment) ?
--
Guido

P.S. : I tried wide open and f/2.8, same bad result in both cases. NOTHING in the photo was in focus, so it shouldn't be a focus shift problem.

 Bart1969's gear list:Bart1969's gear list
Panasonic FZ1000 Fujifilm X-T1 Fujifilm X-T2 Fujifilm XF 35mm F1.4 R Fujifilm XF 10-24mm F4 R OIS +1 more
Sony SLT-A77
If you believe there are incorrect tags, please send us this post using our feedback form.
ForumParentFirstPrevious
Flat view
Post (hide subjects) Posted by
ForumParentFirstPrevious
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow