Can I downgrade firmware from v 2.0.9 to v 2.0.8 on Canon 5D2 ?

Started Sep 25, 2011 | Discussions thread
OP nitroman Regular Member • Posts: 156
Re: Latest Magic Lantern runs with 2.0.9 5D2 firmware

Hi !

I've actually downloaded those firmware files but they look different to the official Canon .fir 2.0.9 i've just downloaded from Canon website. I wonder if one is Mac and one is for Windows PC.

I've spoken to canon Cps (pro service in UK) and they've advised me that it's quite possible to downgrade firmware from new version to older version BUT they advised me to send it in to Canon for them to do it and test. Small service charge would be involved but could be done while I wait.

Interestingly enough, they also advised me that Magic Lantern firmware would not invalidate my Canon Warranty as it's not a hardware modification. Though I'm reluctant to find out for sure

I need Expanded AEB for creating HDR Time Lapse on my 5D2. Three frame EAB just doesn't cut the mustard at the moment ...

-- hide signature --

Professional photographer specialising in people, places and panoramic imagery
http://www.rodedwards.com

 nitroman's gear list:nitroman's gear list
Canon EOS 5DS
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow