Problem with Epson R1800

Started May 7, 2011 | Discussions thread
Shop cameras & lenses ▾
ForumParentFirstPrevious
Flat view
Jeff Peterman
Jeff Peterman Forum Pro • Posts: 11,943
Problem with Epson R1800

I have a problem with my Epson R1800 printer. Recently, I've had to clean the heads about once a week to deal with lines on my prints, which tends to waste a lot of ink. I went to use it yesterday, and it fails the nozzle check every time, even with cleaning - I've burned through about $100 in ink just trying to get a clean result. What's odd is that now I'm getting sudden major blocks across all nozzles that then clears. As you can see in the attached auto-clean results, It almost passed 4 times in a row (with just a few minor drop outs, so it repeated for another row), and then it suddenly failed across all but the blue head. I've seen the exact same pattern of failure several times - sometimes in the first check, others after several rounds where it almost passed.

Any ideas?

-- hide signature --

Jeff Peterman

Any insults, implied anger, bad grammar and bad spelling, are entirely unintentionalal. Sorry.
http://www.pbase.com/jeffp25
http://www.jeffp25.smugmug.com

 Jeff Peterman's gear list:Jeff Peterman's gear list
Panasonic Lumix DMC-FZ40 Canon PowerShot S110 Canon EOS 7D Canon EF-S 10-22mm f/3.5-4.5 USM Canon EF-S 17-55mm f/2.8 IS USM +18 more
ForumParentFirstPrevious
Flat view
ForumParentFirstPrevious
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow