Epson 9600 -- way too magenta with CMS

Started Jan 29, 2011 | Discussions thread
Shop cameras & lenses ▾
ForumParentFirstPrevious
Flat view
Nordstjernen
Nordstjernen Veteran Member • Posts: 6,876
Epson 9600 -- way too magenta with CMS

A friend of mine is running an Epson 9600 from his Windows Vista PC. No matter what we do the prints are way too magenta (both from Photoshop and Lightroom 3).

  • The Epson printer driver is properly installed

  • The screen is calibrated (Eizo 24" Color Edge, eye-1)

  • Image is Adobe RGB 8 bit color space/bit depth

  • Photoshop manages colors, and paper profile is correctly selected

  • Paper profile is set in printer driver, and Color Management is set to Off (no doble color management)

  • Nozzle Check indicates that all ink cardridges are ok

The strange part is that everything looks very nice in Photoshop, and so in Lightroom. But when we push print button, the popup preview turns out way too mangenta, and so does the print! But the image still looks ok in PS and lightroom.

When the printer manages the colors, we get ok results on PS/Lightroom, on popup preview, and the prints looks better (a bit too blue/cyan).

With similar settings on my own system (Epson 9880 and Win 7) the prints looks almost identical to the Photoshop/Lightroom screen image.

Any suggestions?

 Nordstjernen's gear list:Nordstjernen's gear list
Sony SLT-A99 Sony Alpha 7
ForumParentFirstPrevious
Flat view
Post (hide subjects) Posted by
ForumParentFirstPrevious
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow