Finally experienced an SDM failure...

Started Nov 11, 2009 | Discussions thread
ForumParentFirstPrevious
Flat view
Jim King
Jim King Veteran Member • Posts: 8,363
Finally experienced an SDM failure...

Today when I went to use my DA*50-135 the SDM AF was as dead as a doornail. It worked fine a week ago with no sign of impending failure. I tried all of the tricks mentioned in this forum in an attempt to revive it but had no luck. I have made very little use of it actually, so I'm confident that the failure was not due to wear and tear and was not my fault. Bummer!

Of course it's out of warranty (I bought it over two years ago when it was first released) and while the Pentax customer rep was most sympathetic he didn't offer to do anything but accept it for repair on my dime. When I get the repair estimate I'll complain a bit more and try to escalate my case - it surely seems that there are a lot of reports of these SDM/screwdriver dual focusing lenses dying on folks.
--
Jim King - Retired Colormonger - Suburban Detroit, Michigan, USA; GMT -4h (EDT)
Pentaxian for over 45 years.

* * * * *
A fanatic is one who can't change his mind and won't change the subject.

  • Sir Winston Churchill

* * * * *
The difference between genius and stupidity is that genius has its limits.

  • Albert Einstein

 Jim King's gear list:Jim King's gear list
Pentax K-3 Leica M10 Pentax MX-1 Fujifilm X30 Sony RX100 V +117 more
ForumParentFirstPrevious
Flat view
Post (hide subjects) Posted by
ForumParentFirstPrevious
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow