Canon Line Offset Noise

Started Oct 20, 2009 | Discussions thread
bronxbombers Forum Pro • Posts: 18,226
Re: John, Gabor, BB - please consider

you are not the only person to have suggested this

i haven't done it yet, but I do at least have any empty link up to my 'blog' now though

you do make a lot of good points

Sylvain G wrote:
John, thanks for this post...
To you, Gabor, Bronxbombers and other reporters.

I've been following your posts for some time now and have always thought they were a real bonus for the community.

Though, latest posts generated quite some heat that reminded me how forums are, in the end, rarely a good place to get a message across. It just gets too noisy. Your posts get polluted with "go out and shoot", "too much scrutiny","we don't care..." and I think the posts then become totally useless.

My question is...

Have you thought about setting up a quick "blog" with your findings?
I think it would bring several advantages:

-MAINLY : major increase of visibility for the target (Canon?) & users don't have to jump deep into a rather annoying, imho, forum design to find your posts.

-users who actually aren't interested in this issue are less likely to come to a page dedicated on these issues.
-A unique repository of your findings with more flexibility to publish them.
-A moderated space to exchange theories with key users.

Setting up a blog is now only a matter of minutes on wordpress (just an example).

You could then go regularly to several fora of choice (fredmiranda, getdpi, etc...) and link to the blog regularly for interested people and to keep raising awareness of these issues I and many others take very seriously.

The goal is to make some clean noise for Canon to hear and not to get stuck in that maze pattern forum noise (ok, bad pun)

Greetings,
S.

John Sheehy wrote:

In another thread, I mentioned the ease at which Canon can remove artifacts from RAW data. In this post I will demonstrate how simple the offset banding in Canon RAW data is, and how easily it is removed.

The following composite image is the upper left corner of a 7D ISO 100 RAW blackframe. The image is 1000*700 pixels, composed of two versions of a single 1000*350 pixel crop. The top is the RAW data as is, with color interpolation (simple demosaic). The first ~150 columns of pixels is masked in the camera, and sees no light. The top ~32 rows is the same, but something strange is done to that data. I tried using the 27 rows at the top to make a mask to subtract from the RAW image, and the data was not very effective. Too few samples, and some artifacts not seen elsewhere in the RAW. If Canon meant for these to be masked pixels, they really messed it up.

So, for the bottom half, being that the image is a blackframe, and is effectively just like a fully masked image, I made a mask from the bottom 100 rows of pixels (less than 3% of the image height). I took the average in each 100 pixel column, and subtracted it from every pixel in the line. As you can see, even though I took the data used to subtract the banding from the bottom of the image, and my crops are from the top, 3400 pixels away, the pattern cancelled almost perfectly, proving that most of the banding runs at an exact offset, consistently from one end of the image to the other, and is very easily removed.

Now maybe some of you can understand why it is so frustrating to those of us who understand the simplicity of these problems, that Canon leaves this garbage in their RAW files.

Post (hide subjects) Posted by
xxD
xxD
xxD
xxD
xxD
xxD
xxD
xxD
tko
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow