Power pack that DOES WORK with S602z! (so far)

Started Sep 7, 2002 | Discussions thread
Flat view
Alex Tomlinson Junior Member • Posts: 38
Power pack that DOES WORK with S602z! (so far)

Well it's been a rollercoaster ride of emotions over the last couple of days and at one point I really thought I'd killed my camera, but everything is now sorted and I am happy to report that the Ansmann Power Pack Set 2 Plus (£64.95 from http://www.warehouseexpress.com ) DOES WORK WITH THE S602!

See my previous thread for the story so far

After spending most of Thursday morning trying to get through to Fuji UK on the phone (engaged all the time what does that tell you?) I changed tack and called Ansmann in the UK. Got through straight away to a very nice chap who was very keen to help. A couple of hours later he called me back and told me that the power pack had been tested on the Fuji S602's predecessors but not yet with the 602 itself (well it wasn't on his list of compatible models yet). He wasn't able to tell me if the FPP5V sold in Germany was a rebranded Ansmann powerpack as he was still waiting for the main man in Germany to call him back . But as Ansmann do produce a lot of kit that is rebranded by OEM's it was a distinct possibility (never did get an answer to that one).

We decided that it was reasonable to assume that Fuji had probably not made any major changes to such a basic component as the DC input since their previous versions but he wasn't able to gaurantee that the powerpack would work with my camera. I wasn't much further forward.

I decided to risk it and order it anyway (also the Fuji tele conversion lens and one of those groovy little bellows lcd hoods) from wharehouse express. Despite the fact that I'd missed their 2pm deadline for next day delivery it all arrived at 8 am Friday morning. By 9 am the powerpack was charging up and by 3pm the green light was on telling me it was fully charged and ready to go.

This is where things started to get scarey.

I attached all the bits and plugged it into the camera's dc input (a bit of a tight fit but not forcing it) I turned it on and it worked for about a minute or so and then it shut down and wouldn't turn back on again, leaving the lens extended - didn't seem to have enough time to retract the lens, it just went dead.

I had another go and it worked intermittently a couple of times and then shut down alltogether. I decided this was either due to a dodgy connection (at either end) or that the batterypack wasn't properly charged up. The other possibility was that I had just fried all the electronics in my new camera, but thinking about that just made me feel sick.

I'd read somewhere on this forum that rechargable batteries need to be charged up a couple of times and discharged before they settle down and start to work efficiently.

I have to say that the instructions that come with the Ansmann powerpack are poorly translated from the German and don't make much sense. I wasn't sure if it should have been discharged throughly before I'd charged it up.

It doesn't help that it only has a red and a green light and that if the red light flashes it can mean one of several things ranging from it's working perfectly and happily discharging to 'Help I am completely knackered!' I set it to discharge and then recharge itself and went to bed.

This morning things looked a little more positive, the green light was on. I went out and bought some more alkaline batteries so that I could at least see if the camera was totally fried or not.

It worked fine, so I turned off the sleep function and got it all working fine for 10 minutes continuously with no problems. Then I turned it all off and took the batteries out.

When I hooked up the powerpack it worked first time but then as soon as I put the pack (suprisingly heavy) in my top pocket it cut out. Aha! Dodgy connection at the battery end I thought. Sure enough if I held the battery pack up with the cable held tight against the side of the pack everything worked fine.

It was at this point that I noticed a small black hole in the bottom of the (very dark blue) battey case, obviously the lead was meant to feed through here and up inside the case and be held tightly against the body of the battery thus not allowing the jack to swivel at all. Once I got the lead threaded through like this the whole thing worked fine and has continued to work without a hitch ever since.

As yet I haven't done any kind of scientific test to see exactly how long this battery pack will last but as soon as I have an idea I'll let you know. Touch wood it all seems to be working fine for now.


Flat view
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow