Contact cleaner and A700 dials...verdict?

Started Sep 30, 2009 | Discussions thread
Shop cameras & lenses ▾
ForumParentFirstPrevious
Flat view
gipper51 Veteran Member • Posts: 4,391
Contact cleaner and A700 dials...verdict?

My A700 (bought in April 09, 3,800 clicks) just started the infamous issue with the control dials skipping. It's a minor annoyance at this point but sounds like the problem gets worse over time. I've read many posts here with the merits of sending the camera to Sony (and getting lucky they find a problem or fix it right) vs. trying the contact cleaner route.

For those who have tried the contact cleaner, how has it been long term? Does the problem come back after time? Does the cleaning interval get shorter and shorter until it doesn't work?

Just trying to get some feedback on how well this method works long term. Also, what are thoughts on the lubricant type vs. no-residue? Some here have reported the problem returning with the no-residue. Maybe the lubricant is advantageous in the long run? I'm considering the CRC CO cleaner (which I'll have to mail order) or the Radio Shack Tuner Cleaner with lubricant. I've read success stories with both on this forum.
--
Newest galleries:
http://www.pbase.com/gipper51/portraits
http://www.pbase.com/gipper51/architectural

 gipper51's gear list:gipper51's gear list
Canon EOS 6D Sony Alpha 7R Canon EOS 7D Mark II Tamron AF 28-75mm F/2.8 XR Di LD Aspherical (IF) Sigma 12-24mm F4.5-5.6 II DG HSM +7 more
ForumParentFirstPrevious
Flat view
Post (hide subjects) Posted by
ForumParentFirstPrevious
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow