50D Won't format CF Card - but Rebel XT will...

Started Jun 29, 2009 | Discussions thread
Shop cameras & lenses ▾
Flat view
jimr Forum Member • Posts: 53
50D Won't format CF Card - but Rebel XT will...

Hi all,

I have 4 CF cards (2 x 1GB, 1x4GB & 1x8GB), which all work fine in my Rebel XT - and DID work fine in the 50D until just about an hour ago. I picked up the 50D to practise a bit and got the "Card not formatted - format using this camera" error.

Formatting just gave the "cannot format card" error and was advised to try another card. I did... I tried each card I have.

I then tried formatting the cards on my new Sandisk high-capacity card reader (which admittedly, has been giving me troubles). No problem - then there was, then there wasn't.

Finally, the Rebel was used to format the cards (and take sample shots with). No troubles.

Take the cards back to the 50D - and only my oldest (also fastest) Sandisk 1 GB card will work in it. All three others are no good in it now - but work fine in the Rebel XT.

Our printer (Epson RX500) also has a multi-card reader on it, but it never used to read the high-capacity cards. I recently upgraded its drivers and thought I'd try a card. It worked! Then it didn't... I suspect the printer card reader did something making the cards unstable. Does that sound like a possibility?

As a result of this problem, I went to the Canon site and downloaded & installed the newest 50D firmware update.

I have read other threads about cards not formatting, but felt this was a bit different. Anyone have any ideas?

Thanks in for your help,


Flat view
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow