SDM Problems...

Started May 2, 2009 | Discussions thread
ForumParentFirstPrevious
Flat view
rogerstpierre Veteran Member • Posts: 3,984
SDM Problems...

I know there's been ample discussions on SDM issues, but I never seen once seen a post that actually says how those issues were resolve and what caused the issue.

Like many, the SDM on my DA*300 on K10D fails to focus at times (not a new issue for SDM). Only once in a while and is certainly not consistent. Happens once every so many months, it comes and goes, but when it happens, the AF sort of get stuck and becomes unresponsive, even the AF override doesn't work and switching the lens to MF has not effect either. I comes back momentarily when switching the camera to MF and then back to AF mode, but no effect if the lens is switch to MF or either AF modes are selected on the Camera. The only mode that always work is MF if set on the Camera not on the lens. It's not the battery, I've tried switching the battery when it happened last with a fully-charged battery and it had no effect. It's like if the lens isn't getting enough power to fully engage it's internal clutch or something (if there is such a thing).

I'm afraid of sending my Lens to Pentax Service in Toronto only to get it returned to me unfixed because they don't see anything wrong at the time they get it.

-- hide signature --

Roger

 rogerstpierre's gear list:rogerstpierre's gear list
Pentax smc DA 21mm F3.2 AL Limited Pentax Optio 33WR Samsung TL500 Pentax K10D Pentax K-01 +18 more
ForumParentFirstPrevious
Flat view
ForumParentFirstPrevious
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow