Broken SDM: anyone get theirs fixed?...

Started Jul 15, 2008 | Discussions thread
ForumParentFirstPrevious
Flat view
viking79
viking79 Forum Pro • Posts: 14,156
Broken SDM: anyone get theirs fixed?...

As many of you know my SDM in my K20D failed a while back when switching between lenses with my 16-50mm and Sigma 17-35mm.

The symptoms were focus became very loud (the 16-50mm lens has a very loud screw drive), and it would never use the SDM. Also, switching to Liveview caused the camera to shake violently (the shake reduction went crazy). I was afraid it would damage the shake reduction system so I immediately turned it off.

My question is, has anyone else that has had this problem had theirs fixed? My camera is not under warranty (I bought used and seller did not provide an original invoice). I am wondering what was replaced so I have an idea of the cost if I send it in.

I am also wondering if this is systemic issue that will affect many of these cameras, or just an intermittent thing. I believe this is the camera body that failed, as the lens appeared to work fine on another body I tried, but I wonder if it is some interaction between the body and that specific lens that caused it?

Thanks,

Eric

 viking79's gear list:viking79's gear list
Sony a7R Samsung NX1 Samsung NX 30mm F2 Pancake Samsung NX 85mm F1.4 ED SSA Samsung NX 60mm F2.8 Macro ED OIS SSA +5 more
ForumParentFirstPrevious
Flat view
ForumParentFirstPrevious
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow