S85 Won't Recognize Battery After Charging

Started Feb 14, 2002 | Discussions thread
KD Contributing Member • Posts: 605
Re: S85 Won't Recognize Battery After Charging

I had exactly the same problem. Since my camera was still under warranty, I just exchanged it for a new one. Sorry, I couldn't offer you any other solution but to let you know that I had same problem as you. May be you can talk to sony and exchange for a new one.

-- hide signature --


Anne G. wrote:

Hi there-

I wanted to top-off the battery charge of my new S85 for a day of
shooting so I plugged it in overnight. When I turn on the camera it
now shows an empty battery symbol and the LCD display shows "for
INFOLITHIUM battery only."

Has anyone else had this problem before? Could the battery have
overcharged (isn't the system supposed to prevent this?) or could
the battery be defective? I tried taking it out and putting it back
in to no avail. Have not yet tried the reset button. I have
installed a new battery and it was recognized with no problems.

Thanks very much in advance for any and all responses.

Post (hide subjects) Posted by
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow