K10D broke already!!!!

Started Nov 22, 2006 | Discussions thread
ForumParentFirstPrevious
Flat view
Wayne Simpson Contributing Member • Posts: 839
K10D broke already!!!!

I just got home about 1/2 hour ago and was playin around with the K10D, just experimenting, different settings, modes, ISO, whatnot. Then started using flash, again, just playin around. Before I describe what happened, let me ask you guys a question. When using the flash in low light (duh) does it give you a little pre-flash to aquire a better focus? Mine has since day 1. If it's really dark, it seemed to give a small sizzle like strobe, I assumed it was acting like a AF assist light, guess I was wrong! On the last try, it did it's little sizzle thing and then popped, like taking a flash pic, only I hadn't depressed the shutter. Now the cam will not take a pic when the flash is up! Everything else seems to be OK. What the F* K!! Guess I need to return it after 3 days! This S*CKS!!!!!!!!
--
If everything is coming your way, you're in the wrong lane!
Homepage.... http://www.flickr.com/photos/waynespixels/

toys of choice...FZ30...FZ7...BSA RDS...Nikon TC-E17ED...Raynox DCR-250...MCON-40...Nikon 4T...Sunpak 383...Pentax K10D (soon)...Pentax M 50mm f1.7...Pentax F50mm f1.7...Tamron 2X AF TC...Tamron f2.8 28-75...Tamron 70-300 f4-5.6 Di LD Macro

 Wayne Simpson's gear list:Wayne Simpson's gear list
Nikon AF-S 180-400mm F4E TC1.4
ForumParentFirstPrevious
Flat view
Post (hide subjects) Posted by
dfw
lak
(unknown member)
(unknown member)
(unknown member)
(unknown member)
(unknown member)
ForumParentFirstPrevious
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow