Canon EOS 550D (EOS Rebel T2i / EOS Kiss X4)

Announced Feb 8, 2010 •
18 megapixels | 3 screen | APS-C sensor
Canon EOS 550D (EOS Rebel T2i / EOS Kiss X4) Ask a question in forums about the Canon EOS 550D (EOS Rebel T2i / EOS Kiss X4).
Ask a new question
246
Questions
asked
36
Questions
answered
Filter questions by
« First‹ Previous12345Next ›Last »
8
replies
I was wondering if there is any advantage with getting a (cheap) wide angle lens like the Samyang 14mm f/2.8 for the Canon 550D with a cropped sensor? I dont have any local stores to try it out so i wanted to know if would be a waste of time before ordering online. If it helps, i intent to use for filming purposes. Thanks in advance.
47
replies
I am going to Italy in 6 weeks and could use some suggestions as to which lens and/or camera would help me produce some great pictures. I am an intermediate photographer and usually shoot wildlife/nature, but have recently discovered the awe and joy of street photography and architectural buildings, etc. I have the Canon T2i, the kit 18-55, and a 24-105. I have found that the 24-105 does not give me a wide enough angle for many pictures, and oftentimes I cannot move far enough back to get all...
2
replies
Does Tamron SP 150-600mm F/5-6.3 Di VC USD can be use with Canon 550D/600D cameras ?
chleong
By: chleong (2 weeks ago)
13
replies
I just got a 550d body, I am thinking of buying lens(low budget) but I am not sure which lens I should go for. Mainly, I will be shooting landscape, portrait and assist some event. Definitely will get a 50mm f1.8, Besides that, I am thinking to get 18-55mm + 55-250mm or 17-85mm + 75-300mm? which set would be better in terms of sharpness and image quality? Thanks.
0
replies
Hello i have a problem and need help. I have a: Canon 550D firmware 1.0.09 Sharp TV that suppors HD and FULL HD Cable Mini HDMI -> HDMI 1.4 When i connect the camera to a Tv the screen looks like it fallows. Live View Preview And Recording My problem is on the Preview i see full HD display no black stripes. On Recording there are black stripes left right up and down and in the screen 2x grau stripes at the top and bottom. And in Livew View there are stripes left and right screen and 2x...
Owlsu
By: Owlsu (3 weeks ago)
13
replies
Hi, I'm new to this forum but have browsed a lot in the past when reading the wealth of information on here. I currently have a bit of a problem that I'd really like some help with - I've got about £380 to spend on a DSLR body -and- lens together, preferably second-hand from eBay and I'm also preferably looking at Canon or Nikon. About 4 years ago I bought a Nikon D40 which I liked a lot but didn't like the small viewfinder, lack of self-cleaning sensor, low FPS for wildlife photography,...
3
replies
hi friends...i have my 550D near 3 years...and recently i found problem in auto- focus.the lense turns around several times to focus on subject .it really annoy me specially in taking picture a portrait in land scape. it seems to be hard to recognize faces from elements of landscape.finally i should change it to manual mode to focus it...do you know what 's the problem...tnx.
6
replies
I have posted a similar question before, so thank you for all the help so far, but I'm still researching. I take pictures at dance recitals (very low light conditions) and at basketball games. I also take a lot of portraits and dance portraits. I currently have a T2i, but am looking to upgrade. I have been looking mostly at the 70D and the 1D mark iv, but also have looked briefly at the 6D and 7D. It is important that whatever camera I get handles high ISO well, has fast shutter speed (I love...
1
reply
Hi, I hope somebody can help me here... I have an EOS 550D and when i took a picture it told me there was no sd card inside. When i put the sd card in and tried to take new pictures it just did nothing anymore. NOTHING.  Does anybody know how i can get it working again? I tried another sd card and re charged the battery but nothing works... Kind regards, Yannick
2
replies
When using my EF-S 55-250 lens with an ET-60 hood on my 70D I've noticed substantial vignetting on all shots - this was never the case when using it on my 550D.  Once the hood is removed it's fine - any idea why?  It's supposed to be the correct one to use.
Filter questions by
« First‹ Previous12345Next ›Last »