Pentax K-m (K2000)

Announced Sep 22, 2008 •
10 megapixels | 2.7 screen | APS-C sensor
Pentax K-m (K2000) Ask a question in forums about the Pentax K-m (K2000).
Ask a new question
67
Questions
asked
14
Questions
answered
Filter questions by
« First‹ Previous12345Next ›Last »
Ari Aikomus
By: Ari Aikomus (2 months ago)
Posted to: Pentax SLR Talk
37
replies
Hi, I ask a little help. I got used FA* 300/4.5 lens today, and I have tried it now with K-5 body. The lens seems to work basically, but then I noticed that all shots are more or less overexposed, except wide open f/4.5 shots. the smaller the aperture selected from the camera, the more overexposed images...So it seems that the lens doesn't stop down aperture. My other lenses works well with my K-5 body. I tried to clean electrical contacts, no help. Then I tried camera's M-Manual mode, and...
2
replies
Hi there. I love my K3. I'm sure there must be a way to use my old Pentax K-Mount Lens from my ME Super on my K3. I realize that everything will me manual. But, some of my best photos were taken on those manual lenses. Pentax sells a fully Automatic 50mm for the K3. But, I'm not really an Automatic sort of person.Everything meters on the K3 when I try using this lens. But, the shutter just won't work. I'm lost.Any advice? Thomas
42
replies
Hello, maybe you guys can help me :I looked up this website and I was impressed by the the abundance of info but its beyond my experties. so please excuse my silly questions: I am looking for a Video/stills camera that can obtain several parameters that are important to me: 1. i wanna record video with excellent sound already. 2. a camera that has a lens so i can zoom in from 2 KM & still capture a sharp image with good resolution  3. tripod/monopod option 4. take 10 images with a click...
20
replies
I believe I know what the problem is, but I don't want to admit it. Took it out a couple of days ago, the first few shots were fine, then I noticed the darkness creeping in from the left side. It went half way across in a matter of minutes. It is in both the LCD and the EVF. My local guy said he can not fix it because the parts are not available, so it has to go to a Sony authorized repair shop. Has anyone had this done before, and how much did it cost? I have pulled my KMA7D off the bench,...
By: Mumdel (6 months ago)
6
replies
I have had my FZ200 for almost 3 years and have been very pleased with it. However in the last week it has been gradually developing faults. I would like to know if there is a chance it will be fixed economically (sending it almost 2000 km/approx 1200 miles and $70 AUD to quote on it) or whether I should just bite the bullet and replace it.  Initially when selecting Intelligent Auto (iA) on the top dial, it would seemingly randomly jump to some other setting internally. Now it often shows a...
Amamba
By: Amamba (7 months ago)
1
reply
Hi, I own a Sony Nex 6 and, along with Sonys and Sigmas, a handful of Minolta glass, including two Maxxums - 35-70/4 Macro and 70-210/4. Used to have a 50/1.7 and Sigma 12-24 but sold them. My 35-70/4 is one of my overall favorite lenses. It's small, sharp, and most importantly I love the colors it produces. Most of time it's far easier for me to get good skin tones in decent light with that lens than with some other lenses (Sony's AWB is good with skin but not as good as what I got used to...
28
replies
Answered
Somehow it's impossible to get a new long range tele zoom for K-Mount in Germany - besides the Pentax DFA 150-450 which unfortunately is too expensive for me. Neither Sigma nor Tamron do sell them here; Sigma lists the current 150-500 available for Pentax mount on their German website, but don't offer this version even in their own (german) online shop. So in search for a more affordable long range alternative to the DFA 150-450 I've now bought a used Sigma 50-500 - the beloved Bigma - which...
7
replies
Hello all, I'm having an issue with my NX30 when I use an adapted lens on it (I use Canon FDs & Pentak K-Mounts).  The camera will meter correctly at first, but after a couple of shots (or a short period of inactivity), it will not meter correctly and I'll get an underexposed shot.  I then have to turn the camera off, and then back on again to get the camera to meter correctly again.  I usually shoot in manual mode with AUTO ISO.  I tend to see this more when using "Center-weighted" vs...
2
replies
A little while ago I was using the rear screen in the extended position when the screen flickered, then banded with dark lines, then went out. Now when I try to use it, it will power up, back lighting and all, but will not display anything. No photos, menu information, nothing. I looked up some information on replacing screens, but I don't think the symptoms indicated a bad screen, maybe just a connector. I have a shoot next week in North China so I really don't want to mess around getting it...
7
replies
Answered
Does anybody know about the camera equipment on the New Horizons space probe? How did they manage to get images in focus? It may be a stupid question, but sometimes it is easy to miss focus even here on earth :). And near Pluto, you need high aperture value and I assume incredible short shutter speeds and don t have sufficient light. Not exactly a wedding job.
Filter questions by
« First‹ Previous12345Next ›Last »