WST

WST

Joined on Oct 4, 2012

Comments

Total: 2, showing: 1 – 2
In reply to:

RStyga: And, of course, we'll be forced to use the latest Adobe product... How nice of them... 'Sick of their "policy"... Although I own Elements 8, I have to purchase, again, Elements 10 to use ACR 6.7 for my K-01...

To be clear, Adobe isn't updating Camera Raw for it's current version of Elements (10). While I can understand them not going back several versions of Elements, seems like a poor decision to not support the current version. If I want to use Raw files from the latest Rebel I have to wait for Elements 11 to ship (or convert through DNG)

Direct link | Posted on Oct 4, 2012 at 21:19 UTC
In reply to:

Jambsi: Adobe just told me that Camera Raw 7.2 is not available for Elements 10. However it ships with Elements 11.

So, to be clear, Adobe isn't updating Camera Raw for it's current version of Elements. While I can understand them not going back several versions of Elements, seems like a poor version to not support the current version. If I want to use Raw files from the latest Rebel I have to wait for Elements 11 to ship (or convert through DNG)

Direct link | Posted on Oct 4, 2012 at 21:18 UTC
Total: 2, showing: 1 – 2