HoustonPowers

HoustonPowers

Lives in United States Texas,Missouri,Oklahoma,Florida, ME, United States
Joined on Apr 19, 2010

Comments

Total: 9, showing: 1 – 9
On Leica M-Monochrom preview (449 comments in total)

Looks nice

Direct link | Posted on May 10, 2012 at 20:20 UTC as 171st comment
On ICBM in the NUKES challenge (5 comments in total)

Very Nice

Direct link | Posted on May 5, 2012 at 22:24 UTC as 1st comment
On Lightroom 4 Review article (480 comments in total)
In reply to:

quicko58: WHY ARE YOU RIPPING OFF AUSTRALIAN CUSTOMERS ADOBE?

Lightroom v4 has been offered at US $79 for an upgrade $149 full product.
At today's exchange rate that would be just under A$75 (upgrade) or A$141 (Full). The UK store would be even better for us on today's rates at A$73 (upgrade) or A$129 (Full).

Instead these are the prices on the Adobe Store here in Australia

Full Product (Boxed) $219.09 + GST = $241.00
Full Product (Download) $187.00 ex GST
Upgrade (Boxed) $111.25 + GST = $122.38
Upgrade (Download) $98.75 ex GST

I have been a loyal Lightroom user since Version 1 and have also paid for upgrades for both v2 & v3. I wouldn't expect that Adobe would offer it at today's exchange rate but you are not even close. I will be in no hurry to upgrade with the unfair pricing policy that Adobe Australia seem to have in place.

Has Adobe ever addressed or given a reason for the large price differences? Curious why they might be pricing it that way. I imagine there has to be some kind of "internal pricing structure" they adhere to. I can't imagine it's complete greed, or they would have not dropped the price at all, but I am not an accountant or economics expert. Sometimes, with a lower price a larger audience can be reached, but if they are aiming for the general masses it's too pricey. And that goes contrary to selling it at a higher price overseas. I assume there has to be some reason, legitimate or not in our and their minds that would make them follow such a pricing model. I am also sure it was very calculated and researched to death, then settled on what they have now knowing the price discrepancies. I would really like to know if the have talked about it publicly. It does deserve addressing, because their customers have asked and are rightly frustrated.

Direct link | Posted on Mar 8, 2012 at 11:42 UTC
On Lightroom 4 Review article (480 comments in total)
In reply to:

HoustonPowers: I have a small bug in Lightroom 4. When I mouse over the histogram in the Develop Module, the pop up tips are E-mail labels, such as "Mark as read", "Mark as spam" "delete", "reply"..etc..Anyone else have this happening to them?
Just curios if its just my system. Its a peculiar bug.

I dont use the mail app on my mac much, just webmail. The mac mail app is installed of course, but I have not used it in months. I will try an compare the tool tips to see if its from that. I video captured it just in case I needed to show support or something, I may upload it to youtube so others can see it.

Daing it I cant type I will try and re set up my mail program to see if anything happens.

Direct link | Posted on Mar 8, 2012 at 00:47 UTC
On Lightroom 4 Review article (480 comments in total)
In reply to:

HoustonPowers: I have a small bug in Lightroom 4. When I mouse over the histogram in the Develop Module, the pop up tips are E-mail labels, such as "Mark as read", "Mark as spam" "delete", "reply"..etc..Anyone else have this happening to them?
Just curios if its just my system. Its a peculiar bug.

Only using one monitor, no other programs running..just a small bug, no bother, but I thought it was funny, how that could have ended up there.

Direct link | Posted on Mar 7, 2012 at 19:25 UTC
On Lightroom 4 Review article (480 comments in total)
In reply to:

HoustonPowers: I have a small bug in Lightroom 4. When I mouse over the histogram in the Develop Module, the pop up tips are E-mail labels, such as "Mark as read", "Mark as spam" "delete", "reply"..etc..Anyone else have this happening to them?
Just curios if its just my system. Its a peculiar bug.

I was using a mac, no other apps running, same thing happens, and I restarted the computer. Same result. Its not a big deal. I love it so far and havent had any serious issues. I found the tool tips funny because I thought I had something running underneath and kept trying to check my mail program to see what was happening. No big deal for me and good so far with LR 4.

Direct link | Posted on Mar 7, 2012 at 09:05 UTC
On Lightroom 4 Review article (480 comments in total)
In reply to:

HoustonPowers: I have a small bug in Lightroom 4. When I mouse over the histogram in the Develop Module, the pop up tips are E-mail labels, such as "Mark as read", "Mark as spam" "delete", "reply"..etc..Anyone else have this happening to them?
Just curios if its just my system. Its a peculiar bug.

I added a screen-cap to an album (LR 4) in my Galleries for those who are interested.

Direct link | Posted on Mar 7, 2012 at 05:25 UTC
On Lightroom 4 Review article (480 comments in total)

I have a small bug in Lightroom 4. When I mouse over the histogram in the Develop Module, the pop up tips are E-mail labels, such as "Mark as read", "Mark as spam" "delete", "reply"..etc..Anyone else have this happening to them?
Just curios if its just my system. Its a peculiar bug.

Direct link | Posted on Mar 7, 2012 at 05:07 UTC as 68th comment | 7 replies
On Content commenting system launched article (129 comments in total)

This is great, I am a big fan on getting all the news and info out there ASAP..
So thanks!

Direct link | Posted on Jun 22, 2011 at 01:26 UTC as 115th comment
Total: 9, showing: 1 – 9