What is the most recent MBP that supports OS X.6.8?

Started May 4, 2013 | Questions
Shop cameras & lenses ▾
Hen3ry
Hen3ry Forum Pro • Posts: 15,104
What is the most recent MBP that supports OS X.6.8?

And can X.6.8 support the Retina display?

I currently have a mid-2010 MBP with the high rez alternative screen and that works fine.

Cheers, geoff

 Hen3ry's gear list:Hen3ry's gear list
Panasonic Lumix DMC-G6 Panasonic Lumix DMC-GX7 Olympus M.Zuiko Digital ED 9-18mm F4.0-5.6 Panasonic Lumix G Vario 100-300mm F4-5.6 OIS Olympus M.Zuiko Digital 45mm F1.8 +5 more
ANSWER:
Tom_N Forum Pro • Posts: 10,022
Re: What is the most recent MBP that supports OS X.6.8?

All of the Retina MBPs first shipped with Lion or Mountain Lion, so Snow Leopard doesn't support them.

Apple - Mac OS X versions (builds) for computers

It might be possible to buy a copy of Parallels or VMware Fusion, and one of Snow Leopard Server.  Then you could run Snow Leopard Server inside a virtual machine, under (Mountain) Lion.  (It's supposedly a no-no to run the regular Snow Leopard inside of a virtual machine.)

I'm pretty sure that there won't be any Retina Display support in Snow Leopard.  That seems like the sort of thing that would have been an "under the hood" enhancement for Lion.

Tom_N Forum Pro • Posts: 10,022
Re: What is the most recent MBP that supports OS X.6.8?

From Apple's chart, it looks like the last MBPs that can run some version of Snow Leopard are the "Early 2011" ones; you could cross-check with MacTracker to be sure.

selected answer This post was selected as the answer by the original poster.
Hen3ry
Hen3ry OP Forum Pro • Posts: 15,104
Re: What is the most recent MBP that supports OS X.6.8?

Tom_N wrote:

From Apple's chart, it looks like the last MBPs that can run some version of Snow Leopard are the "Early 2011" ones; you could cross-check with MacTracker to be sure.

Many thanks, Tom. Just a point -- when referring to MacTracker it needs to be specified as "MacTracker.ca". There is a mactracker.com but it leads to a non-existent site.

MacTracker.ca tells what OS a Mac was issued with and the latest it can run but makes no mention of earlier OSs it can use.

I notice, though, that while early 2011 models were the last sold with Snow Leopard and the late 2011 models were sold with Lion installed the firmware updates for these models are given as the same: MacBook Pro EFI Update 2.7.

I wonder whether this means the late 2011 models can run OS X.6.8 too.

Cheers, geoff

 Hen3ry's gear list:Hen3ry's gear list
Panasonic Lumix DMC-G6 Panasonic Lumix DMC-GX7 Olympus M.Zuiko Digital ED 9-18mm F4.0-5.6 Panasonic Lumix G Vario 100-300mm F4-5.6 OIS Olympus M.Zuiko Digital 45mm F1.8 +5 more
Keyboard shortcuts:
FForum MMy threads