New 5D MKIII Firmware 1.2.1

Started Apr 19, 2013 | Discussions
waleed
New MemberPosts: 9
Like?
Re: New 5D MKIII Firmware 1.2.1
In reply to slarti bartfast, Apr 26, 2013

my focus speed with speedlite 600ex-rt become super fast

finally they fix it

Reply   Reply with quote   Complain
pso
pso
Veteran MemberPosts: 3,017
Like?
Re: New 5D MKIII Firmware 1.2.1
In reply to waleed, Apr 26, 2013

wowow this is exactly what I am hoping for!  have you tested w/ other flashes too?

waleed wrote:

my focus speed with speedlite 600ex-rt become super fast

finally they fix it

-- hide signature --

Pak K So
'Enjoy your life, guy'

Reply   Reply with quote   Complain
MikeFromMesa
Senior MemberPosts: 2,849
Like?
Re: Whose TC?
In reply to 5DMkIII Shooter, Apr 26, 2013

5DMkIII Shooter wrote:

MikeFromMesa wrote:

Very nice. May I ask whose TC you used? Canon's? If so, which version? If someone else's, whose?

I have been using (occasionally) a non-reporting Kenko 1.4 TC. It works with the current 5D3 firmware because it is non-reporting, but the images are not that good so I don't use it much. Your image is very, very nice and it might be worth getting a new TC if I knew which one you used.

Thanks.

Canon 1.4 Mk II, nice and crisp because aperture is at f8, Af also fast

Thanks, but which version? As I recall Canon had an earlier (and less expensive) TC and a newer (and more expensive) version III. Your image seemed super-sharp and that kind of quality is worth spending the money so I would like to know which version you used.

Reply   Reply with quote   Complain
glaci
New MemberPosts: 6
Like?
Re: New 5D MKIII Firmware 1.2.1
In reply to slarti bartfast, Apr 26, 2013

Sorry to tell you, but there is no AF with Sigma 300-800 f/5.6 DG + Canon 1.4x III Tc.

Reply   Reply with quote   Complain
MikeFromMesa
Senior MemberPosts: 2,849
Like?
Re: New 5D MKIII Firmware 1.2.1
In reply to glaci, Apr 26, 2013

glaci wrote:

Sorry to tell you, but there is no AF with Sigma 300-800 f/5.6 DG + Canon 1.4x III Tc.

I wonder why... It should work.

Reply   Reply with quote   Complain
waleed
New MemberPosts: 9
Like?
Re: New 5D MKIII Firmware 1.2.1
In reply to pso, Apr 26, 2013

man;

it's just perfect

with/without flash

Reply   Reply with quote   Complain
wa2n
Regular MemberPosts: 101
Like?
Re: Whose TC?
In reply to MikeFromMesa, Apr 26, 2013

I used the Canon EF 1.4x II TC for the bird picture w/ new firmware.

MikeFromMesa wrote:

Very nice. May I ask whose TC you used? Canon's? If so, which version? If someone else's, whose?

I have been using (occasionally) a non-reporting Kenko 1.4 TC. It works with the current 5D3 firmware because it is non-reporting, but the images are not that good so I don't use it much. Your image is very, very nice and it might be worth getting a new TC if I knew which one you used.

Thanks.

Reply   Reply with quote   Complain
MikeFromMesa
Senior MemberPosts: 2,849
Like?
Re: Whose TC?
In reply to MikeFromMesa, Apr 26, 2013

My mistake. When I re-read your post I realized you had said which version.

Need to get new glasses!

Reply   Reply with quote   Complain
atodzia
Forum MemberPosts: 56Gear list
Like?
Re: Whose TC?
In reply to wa2n, Apr 26, 2013

There is a link to the firmware on the following page - I haven't tested it.

http://www.cinema5d.com/news/?p=17558

 atodzia's gear list:atodzia's gear list
Canon EOS 7D Mark II Canon EF 100-400mm F4.5-5.6L II
Reply   Reply with quote   Complain
stefanoromei
Junior MemberPosts: 35
Like?
Re: New 5D MKIII Firmware 1.2.1
In reply to MikeFromMesa, Apr 27, 2013

glaci wrote:

Sorry to tell you, but there is no AF with Sigma 300-800 f/5.6 DG + Canon 1.4x III Tc.

I wonder why... It should work.

I think is now working with sigma tc1, 4.

Reply   Reply with quote   Complain
spiderhunter
Regular MemberPosts: 231
Like?
Re: New 5D MKIII Firmware 1.2.1
In reply to slarti bartfast, Apr 28, 2013

Anyone tried the new firmware on the prime 400/5.6 L prime yet - both with and without the 1.4x?

Reply   Reply with quote   Complain
Keyboard shortcuts:
FForum MMy threads