K-30 manual mode question.

Started Mar 16, 2013 | Questions
jojo81
Regular MemberPosts: 119Gear list
Like?
K-30 manual mode question.
Mar 16, 2013

I have the K -30 and the kit lens, I also have a couple of old manual focus lenses with built in aperture rings. (I can get exact models of it makes a difference) when I have the kit lens on I get full manual control of iso, shutter speed, and aperture.  When I use an old lens the camera will only go into A mode, even if I select T or M it still says 'A'.

So i can select the aperture and the iso but not the shutter speed. Is this normal, or am I doing something wrong, is there a setting I can change in the menus to get full control back?

Thanks, Jo Jo.

 jojo81's gear list:jojo81's gear list
Pentax K-30 Sigma 120-400mm F4.5-5.6 DG OS HSM Pentax smc DA 18-55mm F3.5-5.6 AL WR +2 more
ANSWER:
This question has not been answered yet.
Ian Leach
Senior MemberPosts: 1,164
Like?
Re: K-30 manual mode question.
In reply to jojo81, Mar 16, 2013

I don’t know if it is your problem but I recently had issues because I was in auto-iso. The camera will revert to AV even if it is set to Manual. So you may need to fix the iso to one value.

Reply   Reply with quote   Complain
mike703
Veteran MemberPosts: 5,836
Like?
Re: K-30 manual mode question.
In reply to jojo81, Mar 16, 2013

There is a menu option to 'enable aperture ring' which needs to be set to 'Yes'.

Once you have done that you do the following:

set focus to manual

set exposure to manual

select aperture

compose / focus your shot

press green button - this stops down the lens briefly and sets the correct shutter speed based on the aperture / ISO you have chosen

take picture.

There are more detailed descriptions of how to do this around - I'll see if I can find one.

Best wishes

Reply   Reply with quote   Complain
mike703
Veteran MemberPosts: 5,836
Like?
Re: K-30 manual mode question.
In reply to mike703, Mar 16, 2013

Here's one - more or less what I thought - this one is for a K5 not a K30 but same principle.  Good luck

http://forums.dpreview.com/forums/post/51008485

Reply   Reply with quote   Complain
jojo81
Regular MemberPosts: 119Gear list
Like?
Re: K-30 manual mode question.
In reply to Ian Leach, Mar 17, 2013

Ian Leach wrote:

I don’t know if it is your problem but I recently had issues because I was in auto-iso. The camera will revert to AV even if it is set to Manual. So you may need to fix the iso to one value.

Thanks Ian, I'll check that out.

 jojo81's gear list:jojo81's gear list
Pentax K-30 Sigma 120-400mm F4.5-5.6 DG OS HSM Pentax smc DA 18-55mm F3.5-5.6 AL WR +2 more
Reply   Reply with quote   Complain
Keyboard shortcuts:
FForum MMy threads