E-510 hotshoe

Started Mar 3, 2009 | Discussions
Shop cameras & lenses ▾
Garrett_P Regular Member • Posts: 347
E-510 hotshoe
-- hide signature --

My E-510 hotshoe doesn't seem up to the task of securing my FL-50R. I never had a problem with my FL-36. When I mount my 50, even though it is screwed on tight, the hotshoe "wiggles" a bit. Has anyone else had this problem? Is it a big deal?

 Garrett_P's gear list:Garrett_P's gear list
Olympus E-3 Olympus E-520 Olympus PEN E-P3 Olympus Zuiko Digital ED 50mm 1:2.0 Macro Olympus Zuiko Digital ED 12-60mm 1:2.8-4.0 SWD +7 more
Gregm61 Forum Pro • Posts: 14,517
Never noticed any wiggle...

On my E510 or the E520. The flash itself might have just an ever-so slight amount of play to it, but not the cameras' hot shoe.

 Gregm61's gear list:Gregm61's gear list
Leica M9 Panasonic Lumix DMC-GX7 Olympus E-M1 Leica M (Typ 262) Olympus Zuiko Digital ED 50mm 1:2.0 Macro +21 more
kociasek Regular Member • Posts: 167
Re: E-510 hotshoe

HI Garrett, yes, this problem does effect some e510 users attaching FL50. I had the same problem. After some time the screws holding the hotshoe become less tight and the hotshoe starts to wiggle under the strain.

The solution is easy - you need to tighten the 4 screws holding the hotshoe in place. They are on top of the hotshoe, hidden under the small black metal plate. To reveal the screws, you need to slide the plate back.
The procedure is explained here:
http://www.olympusclub.pl/sprzet/naprawa-mocowania-szyny-lampy-blyskowej.html

You don't need to understand the Polish commentary, just scroll down and look at the photos.

Hope this helps.
Marcin
http://flickr.com/photos/lensjoy/

Garrett_P OP Regular Member • Posts: 347
Re: E-510 hotshoe
-- hide signature --

Great! Thanks for the help Marcin...

 Garrett_P's gear list:Garrett_P's gear list
Olympus E-3 Olympus E-520 Olympus PEN E-P3 Olympus Zuiko Digital ED 50mm 1:2.0 Macro Olympus Zuiko Digital ED 12-60mm 1:2.8-4.0 SWD +7 more
Keyboard shortcuts:
FForum MMy threads