k10d hsm focus not working sigma 70-200

Started Jan 1, 2009 | Discussions
zeroflex
New MemberPosts: 7
Like?
k10d hsm focus not working sigma 70-200
Jan 1, 2009

Hello,

i have a k10d, and recently got my fisrt hsm lens, the sigma 70-200.

it worked fine until last weekend. i was taking pictures and suddenly it wouldnt focus anymore.

normal screw driven focus lenses work fine.
man focus works fine too on the 70-200.

when i set my k10d on man. focus i can read it out in my viewfinder that focus is manual.

when i have my k10d on autofocus and set my sigma to manual it says ialso MF in the viewfinder.

i tried another battery, cleaning the contactpins on the camera and on the lens.

does anyone here have some ideas that might help me fix this problem before sending the camera or the lens back? (last december i have had the k10d for 2 years wich is end of warrenty for me)

kind regards

Vincent.

viking79
Forum ProPosts: 13,453Gear list
Like?
Re: k10d hsm focus not working sigma 70-200
In reply to zeroflex, Jan 1, 2009

My SDM in my K20d failed when swapping lenses. This was verified by testing the lens on a different body. If you have access to another SDM camera to try your lens on, I would try that to isolate if the problem is the SDM in your body or the HSM in the lens. I just took my SDM lens to a store that sold Pentax and tried it on one of their demo units.

Sorry to hear that, and good luck!

Eric
--
See my Flickr Photostream: http://www.flickr.com/photos/28177041@N03/
See my PPG Shots: http://www.pentaxphotogallery.com/erictastad
See my Blog/Page: http://web.me.com/atastad/viking79/Welcome.html

 viking79's gear list:viking79's gear list
Sony Alpha 7R Samsung NX30 Samsung NX 30mm F2 Pancake Samsung NX 85mm F1.4 ED SSA Samsung NX 60mm F2.8 Macro ED OIS SSA +5 more
Reply   Reply with quote   Complain
gerard boulanger
Senior MemberPosts: 2,262Gear list
Like?
I had a similar issue...
In reply to viking79, Jan 2, 2009

...

On Pentax 16-50 + 50-135 + 300, all SDN as you know.

I discovered that it's a (very) bad idea to remove a lens with the power ON on the body. Switching power OFF resolved the issue.

I also switch AF button to "M" on the lens barrel before removing it from the body, but there is no need for that, this is just me.

-- hide signature --

Shooting in JPEG is like taking your roll of film to the store to be processed, and when
you get your prints, throwing away the negatives...

 gerard boulanger's gear list:gerard boulanger's gear list
Fujifilm X-Pro1 Fujifilm XF 18mm F2 R Fujifilm XF 35mm F1.4 R Fujifilm XF 60mm F2.4 R Macro Fujifilm XF 27mm F2.8
Reply   Reply with quote   Complain
the victor
Forum MemberPosts: 90
Like?
I have the some problem
In reply to zeroflex, Jan 2, 2009

I have a k10 bought the sigma 70 200 hsm in Sept worked for 2 months then the af started getting slower and slower then it stopped working.
Tried everything mentioned in this thread.
I have a Pentax 16 50 whick works flawless.
Strange how 2 combos, have the some problem
Sorry i don,t have a solution, mine went in for repairs a couples of days ago.
If this thread is still active when i get mine back i,ll post the result.

Reply   Reply with quote   Complain
Zebooka
Contributing MemberPosts: 606Gear list
Like?
Re: k10d hsm focus not working sigma 70-200
In reply to zeroflex, Jan 2, 2009

For last half-a-year I've counted lots of threads saying about problems with SDM autofocus. Here on dpreview and on other forums.

Now I'm thinking what 70-200/2.8 to buy. I guess Tamron...

To solve problem, maybe one should do:
1) clean contacts
2) reboot camera with removing battery away, but not just powering-off.
3) checking lens is properly locked in bayonet

-- hide signature --

Taiga, Siberia, Russia I'm photo-journalist
My web site - http://www.zebooka.com

Reply   Reply with quote   Complain
zeroflex
New MemberPosts: 7
Like?
Re: k10d hsm focus not working sigma 70-200
In reply to Zebooka, Jan 6, 2009

Thx for the input.

i have tried the lens on a k20d body in a shop here in town. the lens olso didnt autofocus on the k20d body in the store.

i wil sent the lens for repair.

kind regards

Vincent

Reply   Reply with quote   Complain
brandrx
Forum ProPosts: 25,870
Like?
Re: k10d hsm focus not working sigma 70-200
In reply to zeroflex, Jan 6, 2009

I am sure you have already checked but I will ask it anyway. Have you checked the AF/MF switch on the lens that it is in AF? Try switching it back and forth a couple of times.

Cheers.

-- hide signature --

'Keep your eyes looking forward. However, glance back now and then to see where you've come from. It will put a smile on your face.' ~ brandrx

http://en.wikipedia.org/wiki/Carbon_County,_Utah

Ron ~ Retired.

Reply   Reply with quote   Complain
Demarp
Contributing MemberPosts: 851
Like?
Re: k10d hsm focus not working sigma 70-200
In reply to brandrx, Feb 19, 2009

I have just found this thread ! because I am having the same problem ?
Tomorrow I am going to the camera store !
Anyone resolved this problem ? thanks
--
--K10D--
Sigma 105mm F2.8 EX DG MACRO
Sigma 24-70mm F2.8 EX DG MACRO
Sigma 70-200 F2.8 EX DG MACRO II
Pentax SMC FA 50mm F1.7

http://www.flickr.com/photos/pdemartin/

Reply   Reply with quote   Complain
the victor
Forum MemberPosts: 90
Like?
Re: k10d hsm focus not working sigma 70-200
In reply to Demarp, Feb 19, 2009

See my post further up.
Yep
Got mine back from Sigma last week.
Complete new hsm assembly was fitted.

Reply   Reply with quote   Complain
Taffy
Veteran MemberPosts: 4,523
Like?
Re: k10d hsm focus not working sigma 70-200. Been following this thread
In reply to the victor, Feb 19, 2009

It's good to know that it was the lens at fault, and therefore, Sigma's QC, and not, Pentax to blame. Good luck with your lens, now that it has been fixed.
--
Regards Allan.

Reply   Reply with quote   Complain
dijkx
Contributing MemberPosts: 513Gear list
Like?
Re: k10d hsm focus not working sigma 70-200. Been following this thread
In reply to Taffy, Feb 19, 2009

I had the same problem, the first time the focus stopped working I had been outside where it was nearly freezing the focus went slower and slower and in the end it stopped at all. After I had the lens near the heating for a while it was working again. The second time the lens stopped focussing I was outside again and again it was very cold, the heating trick did not work so I send my lens in for repairs. Now the lens seems to focus faster than ever en even in cold conditions there is no problem anymore.
Was your lens exposed to the cold ?????
--

http://www.dijkx.com

 dijkx's gear list:dijkx's gear list
Pentax K-3
Reply   Reply with quote   Complain
Jan from SVK
Forum MemberPosts: 55
Like?
Re: k10d hsm focus not working sigma 70-200. Been following this thread
In reply to dijkx, Feb 19, 2009

I have the same problem with my Sigma 70-200 and K10D. Received lens two weeks ago and worked inside properly. Then I tried use it outside and did not focus. There was aprox.2 or 3 deg Celsius below zero. After that I tried in standard condition 20 deg and again did not focus.
Also I think lens got slower and slower.

Reply   Reply with quote   Complain
Demarp
Contributing MemberPosts: 851
Like?
Re: k10d hsm focus not working sigma 70-200. Been following this thread
In reply to Taffy, Feb 19, 2009

I went to the store and the lens is working fine on 2 bodys so I have sent my Body to pentax
but read this thread I have just wrote
http://forums.dpreview.com/forums/readflat.asp?forum=1036&thread=31057625
--
--K10D--
Sigma 105mm F2.8 EX DG MACRO
Sigma 24-70mm F2.8 EX DG MACRO
Sigma 70-200 F2.8 EX DG MACRO II
Pentax SMC FA 50mm F1.7

http://www.flickr.com/photos/pdemartin/

Reply   Reply with quote   Complain
dijkx
Contributing MemberPosts: 513Gear list
Like?
Re: k10d hsm focus not working sigma 70-200. Been following this thread
In reply to Jan from SVK, Feb 20, 2009

Jan from SVK wrote:

I have the same problem with my Sigma 70-200 and K10D. Received lens
two weeks ago and worked inside properly. Then I tried use it outside
and did not focus. There was aprox.2 or 3 deg Celsius below zero.
After that I tried in standard condition 20 deg and again did not
focus.
Also I think lens got slower and slower.

So temperature could be the problem, after the repair I took my lens to an indoor ski hall. It was -6 degrees celcius and my lens had no problems anymore

-- hide signature --
 dijkx's gear list:dijkx's gear list
Pentax K-3
Reply   Reply with quote   Complain
Keyboard shortcuts:
FForum MMy threads