Dead S100

Started 4 weeks ago | Discussions thread
ForumParentFirstPreviousNextNext unread
Flat view
Emil17
New MemberPosts: 3
Like?
Dead S100
4 weeks ago

Hi,

I'm curious if anybody else has a S100 die on them. I've taken great care with the camera, keeping it in a case, etc. It hasn't gotten wet, dropped it, etc. Unfortunately, on the first day of a vacation, the camera stopped working. At times, it will power on and a few pictures can be taken. Then it will die, and become completely unresponsive. The lense will stay extended, screen completely blank, and the power button will do nothing. Then, for some random reason, it will power on/off again. It's will again, take a couple of pictures before repeating.

I've called Canon, and all they had me try was resetting the factory default settings, and then removing the battery and holding down the shutter button for 30 seconds. It is out of warranty. so it's send in for repair or go through the Canon Loyalty program and get a discount on a refurb...

I loved my last Powershot that was put through a lot. This really makes be doubt the quality of Canon's product. The camera is barely 2 years old.

Any experience or advice?

Thanks,

Emil

Kodak Pixpro S-1
If you believe there are incorrect tags, please send us this post using our feedback form.
ForumParentFirstPreviousNextNext unread
Flat view
Post (hide subjects)Posted by
ForumParentFirstPreviousNextNext unread
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark post MMy threads
Color scheme? Blue / Yellow