Problem with the new Rokinon RMC Fisheye lens and V2

Started 3 months ago | Discussions thread
ForumParentFirstPreviousNextNext unread
Flat view
HGFGKM
Regular MemberPosts: 208Gear list
Like?
Problem with the new Rokinon RMC Fisheye lens and V2
3 months ago

I received the new Rokinon fisheye lens recently announced and discussed in this forum. I connected it to the V2 in Manual mode and turned it on, following the instructions in the sheet that came with the lens. In Manual mode, the screen and the EVF are flashing. The shutter release works but no photo is taken. In A or S mode, a message comes stating "Check lens. Pictures can only be taken when a lens is attached". Apparently the camera does not recognize the lens at all, even though it was made for Nikon 1 V cameras (stated in the lens instruction sheet). I searched throughout the V2 manual and the web and I cannot find any way to run the camera without it perceiving that a lens is attached.

Is there something I am missing? Has anybody else used this lens with V2 or any other V or simply Nikon 1 camera?

I would be thankful for any suggestions.

 HGFGKM's gear list:HGFGKM's gear list
Sony RX100 Sony Alpha NEX-7 Nikon 1 V2 Nikon D610 Nikon AF-S Nikkor 28-300mm f/3.5-5.6G ED VR +8 more
Nikon 1 V2
If you believe there are incorrect tags, please send us this post using our feedback form.
ForumParentFirstPreviousNextNext unread
Flat view
Post (hide subjects)Posted by
ForumParentFirstPreviousNextNext unread
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark post MMy threads
Color scheme? Blue / Yellow