Lightroom 5 very slow

Started Aug 23, 2014 | Discussions thread
Shop cameras & lenses ▾
ForumParentFirstPreviousNextNext unread
Flat view
Forum MemberPosts: 91Gear list
Lightroom 5 very slow
Aug 23, 2014

I'm finding LR 5 very slow.  In Develop module, sometimes the Downloading msg seems to just stay there forever.  Full screen view can also take a long while & sometimes hangs completely. Once an image is loaded into Develop, it runs just fine when editing.

5.4 used to be generally OK but I upgraded to 5.5 & had to revert back to 5.4 due to performance issues.  I tried an upgrade to 5.6 but quickly went back to 5.4 as it was so slow.

I'm running 64bit on a quad core PC with 16Gb RAM so that shouldn't be the issue.  The CPU & memory utilisation when running LR is quite low.

I'm currently moving my libraries from a USB2 to a USB3 disk to see if that helps, but I doubt it will as the slowdown I can't handle is when the library has fully loaded.

In case it is relevant, moving an image to PS is also slow but I don't do that too often so it isn't a real issue.

Does anyone have any performance enhancing tips please?

Many thanks


 Muggo's gear list:Muggo's gear list
Canon EOS 6D Canon EF 50mm f/1.8 II Canon EF 100mm f/2.0 USM Canon EF 17-40mm f/4.0L USM Canon EF 100-300mm f/4.5-5.6 USM +1 more
ForumParentFirstPreviousNextNext unread
Flat view
ForumParentFirstPreviousNextNext unread
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark post MMy threads
Color scheme? Blue / Yellow