Canon 70D AI Servo focus issue for BIF

Started 4 months ago | Discussions thread
ForumParentFirstPreviousNextNext unread
Flat view
dgumshu
Regular MemberPosts: 464
Like?
Canon 70D AI Servo focus issue for BIF
4 months ago

I've been trying to get satisfactory results using various settings on my 70D and 100-400mm L for BIF using AI Servo, but the number of keepers is very low.  It seems as though I can't really get sharp shots, especially around the eyes.   Lots of  out of focus shots.

Surprisingly, I get much better results using my slower 6D in AI Servo using the same settings. On both bodies I use aperture priority, f8 or higher as  I've experienced DOF issues with lower f stops.  I've got the ISO set to 400 to keep the shutter speed over 1600.  I'm using the center focus point in high burst mode.   I don't like using shutter priority as I don't like loosing control of the f stops.

I've made some micro focus adjustments, but haven't had the opportunity to test that out as of yet.  I was thinking of buying the 400mm L  prime to use with this 70D, but  I'm not so sure that will make a difference if it is an AI Servo focus issue.   The 100-400 seems to work much better on the 6D.

Anyone else experience  this using the 70D and 100-400?

Canon EOS 70D
If you believe there are incorrect tags, please send us this post using our feedback form.
ForumParentFirstPreviousNextNext unread
Flat view
ForumParentFirstPreviousNextNext unread
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark post MMy threads
Color scheme? Blue / Yellow