BUSY on 60D

Started 4 months ago | Questions thread
ForumParentFirstPreviousNextNext unread
Flat view
rorosmomma
New MemberPosts: 1
Like?
BUSY on 60D
4 months ago

I have a 60D. It worked perfectly last week. This week when I tried to take photos I keep getting a BUSY error.
I push the shutter button and it's like it takes the photo but doesn't release. No photo is recorded.
Sorry for the lack of professional lingo.
Any suggestions? I've changed the lens. I tried the same lens on my rebel. It works fine on the rebel. No lens will work on my 60D. Is it the camera body?!
It does this when shooting automatic and manual. 
I also tried switching the memory card.

ANSWER:
This question has not been answered yet.
Canon EOS 60D
If you believe there are incorrect tags, please send us this post using our feedback form.
ForumParentFirstPreviousNextNext unread
Flat view
Post (hide subjects)Posted by
ForumParentFirstPreviousNextNext unread
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark post MMy threads
Color scheme? Blue / Yellow