AF problem with the Sigma 35mm A

Started 4 months ago | Questions thread
ForumParentFirstPreviousNextNext unread
Flat view
Dr Glyco
New MemberPosts: 11Gear list
Like?
AF problem with the Sigma 35mm A
4 months ago

I have problems to get good focus with my Sigma 35mm Art lens. Most often I challenge the lens and use f/1.4 but I think it misses focus, about half the times, also at f/2.8 and higher. Thing is, I first had the D600 and had no AF problems. Now, using D610 I had problems also after calibration using the USB-dock. I sent the lens to Sigma and they adjusted the values for the dock (Strange, since this setting largely should be camera specific?) The new values were +11, +11, +12, +14. I hope they also did some hardware calibration of the lens.

Now I have discovered that I consistently get good focus using liveview AF. But it misses almost all the time using the OVF. Am I likely to have problem with my camera? Or is this more expected to still be depending on the shitty performance/calibration of my lens? I have no AF problems with my 85mm 1.8G

-- hide signature --

Jonas

 Dr Glyco's gear list:Dr Glyco's gear list
Sony RX100 Nikon D610 Nikon AF-S Micro-Nikkor 60mm f/2.8G ED Nikon AF-S Nikkor 85mm f/1.4G Nikon AF-S Nikkor 50mm f/1.8G +2 more
ANSWER:
Nikon D600 Nikon D610
If you believe there are incorrect tags, please send us this post using our feedback form.
ForumParentFirstPreviousNextNext unread
Flat view
ForumParentFirstPreviousNextNext unread
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark post MMy threads
Color scheme? Blue / Yellow