Live view on E-510 & BLM1 drain

Started 1 month ago | Discussions thread
ForumParentFirstPreviousNextNext unread
Flat view
photophile
Forum ProPosts: 12,894Gear list
Like?
Live view on E-510 & BLM1 drain
1 month ago

A first I blamed the 3rd party BLM1's that I have accumulated over the years. I thought they'd come to the end of their lives and were no longer charging fully. But after a bit of tinkering, I discovered that it was the Live-view mode on my E510 which, when engaged, gave the low battery signal almost straight away - and within a few seconds, shut the camera down.  But when I inserted the same battery into my E500 or C-8080 - its still showed green - and continued working as normal.

I never use the live view mode - so perhaps that's why its taken me so long to discover this phenomenon.  Does it to all the batteries. And only when the livew-view is turned on.  I take it the camera has developed a fault.

Anyone else have a similar experience ?

-- hide signature --

AH

 photophile's gear list:photophile's gear list
Olympus Stylus 840 Olympus C-8080 Wide Zoom Olympus C-750 UZ Olympus E-500 Olympus E-510 +5 more
Olympus E-5
If you believe there are incorrect tags, please send us this post using our feedback form.
ForumParentFirstPreviousNextNext unread
Flat view
Post (hide subjects)Posted by
ForumParentFirstPreviousNextNext unread
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark post MMy threads
Color scheme? Blue / Yellow