5d3 Powers down but then won't power up with tap of shutter button

Started 1 month ago | Discussions thread
ForumParentFirstPreviousNextNext unread
Flat view
T Nels
Forum MemberPosts: 94Gear list
Like?
5d3 Powers down but then won't power up with tap of shutter button
1 month ago

I shot a wedding today with 5d3 and 24-70l.  Had T3i and other lenses for back up.  Toward the end of the evening my 5D3 started acting erratically.  It would power down and not power back up with a tap of the shutter button.  Several times I had to turn the power switch off and back on.  After a period of time, that wouldn't solve the problem and I then took the battery out of the camera and put it back in.  That seemed to work for awhile but then that didn't work either.  I made it through the event with T3i completing my shots at reception.  The battery indicates its still at 50% power.  It's the original battery that came with the body and the 24-105 I purchased as a kit.

After arriving home, I thought maybe by updating the firmware, I could solve the problem.  I successfully did that, but still have these intermittent issues.

Has anybody experienced this?  Or, can you diagnose the problem?  I have a feeling this will be the first time I have to send in a piece of equipment to Canon.

Thanks for any help you can provide!!!

 T Nels's gear list:T Nels's gear list
Canon EOS 600D Canon EOS 5D Mark III Canon EF 50mm f/1.4 USM Canon EF 300mm f/4.0L IS USM Canon EF-S 10-22mm f/3.5-4.5 USM +7 more
Canon EOS 5D Mark III Canon EOS 600D (EOS Rebel T3i / EOS Kiss X5)
If you believe there are incorrect tags, please send us this post using our feedback form.
ForumParentFirstPreviousNextNext unread
Flat view
ForumParentFirstPreviousNextNext unread
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark post MMy threads
Color scheme? Blue / Yellow