Issue with Sigma 17-50mm f/2.8 ex dc os hsm when using with D7100

Started 3 months ago | Discussions thread
UtenteMac
Junior MemberPosts: 41
Like?
Re: Issue with Sigma 17-50mm f/2.8 ex dc os hsm when using with D7100
In reply to richiebee, 3 months ago

Bought a D7100 and the Sigma 17-50 in the past two weeks, so everything pretty much up to date.

The preview bug where you can't keep pressed the arrow pad is quite annoying. This is fine when you don't recompose focus and you're interested just in the autofocus zone, buts shooting landscapes and such, having to quickly check most of the scene by frenetically press the controls is a pita.

The OS bug is much worse, not only the battery draining is a magnitude higher than the one on my old D300, but it's reported as always ON even when the switch is OFF. Someone told the switch should work as expected, but I'm not really 100% sure about that.

Being reported as always on it prevents focus calibration with softwares like FoCal, which explicitly tells to disable any form of optical stabilization. Lacking a way to force it to go on no matter what it simply stops after the first step.

Having said that is a good quality lens that you simply can't beat on a price standpoint. I'd happily pay more for a similar version without issues but either it doesn't exists or introduces other issue like inferior sharpness, such as the old Nikkor.

Reply   Reply with quote   Complain
Post (hide subjects)Posted by
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark post MMy threads
Color scheme? Blue / Yellow