Nikon D70s CHA error, random symbols, corruption

Started 3 months ago | Questions thread
ForumParentFirstPreviousNextNext unread
Flat view
mayam
New MemberPosts: 1
Like?
Nikon D70s CHA error, random symbols, corruption
3 months ago

Hi everyone,

I hope this thread is in the right place and sorry if this is long.

I've come to you all for help. I got a Nikon D70s years ago and have used it a lot. I regularly get the annoying as crap CHA error but removing and reinserting the card seems to "fix" it enough that I can take my pictures.

Lately in the past few weeks the CHA error has been happening more and more to the point where I can't hardly take 2 pictures without having to reinsert the card (no idea why it's doing that so frequently). Today it's all come to a head though because when I tried to transfer the pictures to my computer this happened:

wtf?? Normally it says Nikon D70 (H:) but now it's a bunch of random symbols. Here is what it looks like when I clicked on it:

I can't find any picture files to copy. It's just symbols and if I scroll down there's a bunch more files and folders with symbols and random dates. If I click on a folder it will say that either it's inaccessible, does not exist, or it doesn't do anything if I click it.

I attempted to format the card but it won't let me. The "Start" button is greyed out. So I can't even format the thing.

I use a Lexar 1GB CF card and a card reader. I'm at a loss. Please if you know how to fix this or have any suggestions do let me know. Do I need a new card? New camera? What should I do? Thanks.

ANSWER:
This question has not been answered yet.
Nikon D70s
If you believe there are incorrect tags, please send us this post using our feedback form.
ForumParentFirstPreviousNextNext unread
Flat view
Post (hide subjects)Posted by
ForumParentFirstPreviousNextNext unread
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark post MMy threads
Color scheme? Blue / Yellow