DXO Optics Pro and E-M1

Started Jul 17, 2014 | Discussions thread
Shop cameras & lenses ▾
(unknown member) Senior Member • Posts: 1,803
Re: The E-M1 requires the most expensive version?

PurpleFringe wrote:

It looks like you need the 'Elite' version at twice the price for the E-M1 (but not for the E-M5 or GX-7). Apparently they are using the price of the camera to determine the price of the software. Interesting.

But - they have some for of Lightroom integration, which makes it possible for me to use without having to manage multiple formats and versions of the same photo. That's a plus.

It's a lot better than the pricing they used to do.

Post (hide subjects) Posted by
(unknown member)
(unknown member)
(unknown member)
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow