Play Memories on MAC not working

Started 1 month ago | Discussions thread
halfmonkey
Regular MemberPosts: 143Gear list
Like?
Re: Play Memories on MAC not working
In reply to Kev The Doc, 1 month ago

Kev The Doc wrote:

Hi All,

Is anybody else having problems running Sony's Play Memories on a MAC running Mavericks? I've loaded and unloaded several times and need this to wireless transfer pics from my Sony A6000 to the MAC unless there's another way around this?

Also when I connect the camera to MAC vs USB it doesn't connect for some reason?

Is there any other way of getting pics from the camera to the MAC without having to remove the SD card each time and plug it into MAC?

Mine wouldn't work either and I believe it had an error message saying something about the browser. I tried numerous times. I have Mavericks and after a while I gave up trying to connect with through my computer.

The best way to do it, at least how I do it, is simply go through your camera and log in that way. You can view the available apps, purchase them through the camera, and download them through the camera. It's a little more cumbersome but at least it'll get the job done. I actually log into my sony account through the computer first and update my acct info with my credit card information and then log out. I then log in through my camera and make the purchase because even if you have money on your sony account, it won't let you make the purchase without credit card info. Once you do this and make the purchase through the camera, you can log back into your sony acct and delete your credit card info.

 halfmonkey's gear list:halfmonkey's gear list
Sony Alpha 7
Reply   Reply with quote   Complain
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark post MMy threads
Color scheme? Blue / Yellow