Sony a77M2 SD card compatibility issue

Started 5 months ago | Discussions thread
ForumParentFirstPreviousNextNext unread
Flat view
DebCamPhoto
New MemberPosts: 11Gear list
Like?
Sony a77M2 SD card compatibility issue
5 months ago

I have had my new camera about 3 weeks now. The first SD card I put in it was the Sony 16GB UHS-1 SD/SDHC Memory Card 94MB/s Class 10. Third shot I received an error message.

'Writing to the memory card was not completed correctly. Recover data?' I then hit 'Enter' and the next message that comes up on the screen is 'Execute? This may damage date that was added or edited on another device'.

I removed the card, reinserted it, formatted and tried again and again received same error message. Since then, I have been using an older Lexar 16gb Platinum II 100x card with no problems. Today I tried a Lexar 16GB SDHC Memory Card Professional Class 10 600x UHS-I and again started receiving the same error message.

What is going on? Why are these newer high speed cards not working on this camera?

I will gladly purchase new cards if I know they are reliable, but don't want to order a card not knowing if it will work in this camera.

Can anyone tell me what is going on here and recommend a solution or the SD cards I need to be using? Thanks!

 DebCamPhoto's gear list:DebCamPhoto's gear list
Sony SLT-A77 Sony a77 II Sigma 10-20mm F4-5.6 EX DC HSM Sony 70-300mm F4.5-5.6 G SSM Sony 70-400mm F4-5.6 G SSM +3 more
Sony SLT-A77
If you believe there are incorrect tags, please send us this post using our feedback form.
ForumParentFirstPreviousNextNext unread
Flat view
Post (hide subjects)Posted by
ForumParentFirstPreviousNextNext unread
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark post MMy threads
Color scheme? Blue / Yellow