SD10 repaired + some shots with Super Takumar 50/1.4

Started Jun 29, 2014 | Photos thread
Shop cameras & lenses ▾
ForumParentFirstPrevious
Flat view
dr.noise
dr.noise Veteran Member • Posts: 3,540
SD10 repaired + some shots with Super Takumar 50/1.4
2

My SD10's rubber buttons have almost stopped working, I thought that if I disassemble the camera and clean the contacts they will start working again, but silly me. What I did is cleaning the last of the conductive coating from these buttons and they stopped working for good.

Hours later, I made little foil pads from drug blister and attached them to the back of the buttons with double-sided scotch. Just after that I found a conductive glue on Ebay so I think I'll try it next time.

Now buttons are working like new, so I went to make some shots with Pentax Super Takumar 50/1.4. The lens happened to be mostly too long for this shoot, had difficulties with framing. Also many misses with manual focus. Also the exposure meter went mad. Also it has yellowed glass. Also it is very intolerant to contra light, producing some kind of Instagram-inspired pics. I wonder, is this normal for the Takumar?

 dr.noise's gear list:dr.noise's gear list
Sigma DP2s Sigma SD10
Comment & critique:
Please provide me constructive critique and criticism.
Sigma SD10
If you believe there are incorrect tags, please send us this post using our feedback form.
ForumParentFirstPrevious
Flat view
ForumParentFirstPrevious
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow