X100s & EF-42 Flash

Started 2 months ago | Questions thread
ForumParentFirstPreviousNextNext unread
Flat view
ryan2007
Veteran MemberPosts: 8,343Gear list
Like?
X100s & EF-42 Flash
2 months ago

Has anyone used the EF-42 with the X100s and the flash sporadically worked.  Just had a last minute job today to shoot some real estate photos in preparation for a house sale/put images on line.

Had the X100s, 28 mm, EF-42 and a self-standing mono-pod.

Things going great and Murphy's Law decided to see me today.  Batteries were fresh lithiums etc and worked no problem for a while.

At a point the flash stops working. Removed batteries, turned off power etc.

*In the end that Mono-Pod saved the day with no flash allowing for shutter speeds I certainly could not hand hold more so with No image stabilization.

Anyone ever have flash issues with the Fuji X cameras?

As this was occurring I all but said to myself this is not the camera system when flash is needed. I never had this occur with other systems. Just frustrated on that moment.

I all but wanted to get a DSLR or something else to get this done.

On that note I just got a portable strobe/Mono-Light the Interfit Stellar Extreme 300 w/s strobe with battery pack. Point is if you do not have A/C the battery kicks in for power and that would have come in handy.

Anyway in the middle of the 16 hour prep to get this thing fully charged and conditioned per the manufacture. I do have Elinchrome mono-lights but they need A/C.  Hope this works out ok.

 ryan2007's gear list:ryan2007's gear list
Fujifilm X100S
ANSWER:
This question has not been answered yet.
Fujifilm X100S
If you believe there are incorrect tags, please send us this post using our feedback form.
ForumParentFirstPreviousNextNext unread
Flat view
ForumParentFirstPreviousNextNext unread
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark post MMy threads
Color scheme? Blue / Yellow