True that DPP4 does not work with 5DII files?

Started 5 months ago | Discussions thread
Paul Holman
Junior MemberPosts: 39
Like?
Re: True that DPP4 does not work with 5DII files?
In reply to rrccad, 5 months ago

rrccad wrote:

Heck even the prosumer 5D Mark II is 5+ years old now.

they still continually update and support DPP 3.x - i fail to see the insult.......

case in point - DPP 1.5 was shipped with the 1Ds mark II. you've enjoyed countless revisions up to 3.9.x. without any fees over the past 10 years and are still supported to this day as there is 3.9.14 being released by the end of the month.

So 5 years old is too old to continue offering software support ? Other companies manage better.

DPP 4 is supposedly a 'significant upgrade' so why exclude older files from it ? Much of the lauded improvements are about usability and speed, both aspects that badly let previous versions down. So Canon finally address the criticisms of previous versions, but exclude their previous customers from the improvements they asked for. It's not good business.

Reply   Reply with quote   Complain
Post (hide subjects)Posted by
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark post MMy threads
Color scheme? Blue / Yellow