E-P5 firmware 1.5 update - what am I doing wrong?

Started May 25, 2014 | Questions thread
Shop cameras & lenses ▾
ForumParentFirstPreviousNextNext unread
Flat view
James Pilcher
Veteran MemberPosts: 8,285Gear list
Like?
E-P5 firmware 1.5 update - what am I doing wrong?
May 25, 2014

Now I remember why I dislike the Olympus method of updating cameras and lenses so much. I recently purchased an E-P5 with the original firmware version 1.0 in place. I want to apply v1.5. I downloaded and installed the Olympus Updater and began the update. No matter what I do, I get this message:

Error 0x80041037

The software recognizes the camera just fine. I have tried connecting the camera to the computer both before and after I start the Updater. I rebooted the computer after the Updater installation. I have a perfectly good, and very fast Internet connection in my home and it is operating just fine on this computer.

Windows 7, 64 bit.

I searched this forum for the error number, but found nothing. I find nothing in a Bing/Google search on the Internet.

What am I doing wrong?

Jim Pilcher
Summit County, Colorado, USA

 James Pilcher's gear list:James Pilcher's gear list
Panasonic Leica Summilux DG 25mm F1.4 Olympus M.Zuiko Digital ED 12mm 1:2 Olympus M.Zuiko Digital ED 75mm F1.8 Panasonic Lumix DMC-LX7 Olympus PEN E-P5 +7 more
ANSWER:
Olympus PEN E-P5
If you believe there are incorrect tags, please send us this post using our feedback form.
ForumParentFirstPreviousNextNext unread
Flat view
Post (hide subjects)Posted by
(unknown member)
(unknown member)
ForumParentFirstPreviousNextNext unread
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark post MMy threads
Color scheme? Blue / Yellow